UAT Pricing Outage (Portal Only)

Incident Report for B2C2

Resolved

This incident has been resolved.
Posted Jan 14, 2025 - 13:12 UTC

Investigating

We are currently investigating this issue.
Posted Jan 14, 2025 - 11:48 UTC
This incident affected: UAT (OTC Portal).